Customers, Google has decided to move forward to the future industry-standard for cybersecurity, which will be TLS 1.2, and is placing that warning on websites which use the current standard TLS 1.0 Security for end-to-end encryption; but aren’t fully-upgraded with TLS 1.1/1.2. All other web browsers will not show this warning until the Payment Card Industry (PCI) makes this upgrade the standard mandatory. This date is scheduled for June 1, 2017. The Auto-Bill Pay site using Google Chrome is Secure and meets all standards to date.
 
Utilities Self Service
Should you require assistance, please call 561-243-7100.
Account Number:  -
(Located in the top right corner of your statement. ex: 12345-98765)